Running Tortoise 3.1.2 under recent MacOS versions (High Sierra, Mojave)?

Submitted by timschaefer on

We installed Tortoise 3.1.2 from here under MacOS (we tried both High Sierra and Majave, the latest 2 versions) and followed the manual to process our data. But at the first step (data import), the ComputeGlyphMaps command fails:

When running ComputeGlyphMaps, I get the following error (even when running witout any command line arguments):

$ ComputeGlyphMaps
dyld: Library not loaded: /Users/irfanogo_local/Desktop/UK_trip_data_software_code/code/libraries/VTK801_build/lib/libvtkDomainsChemistryOpenGL2-8.0.1.dylib
  Referenced from: /Users/ts/software/TORTOISE_V3.1.2/DIFFCALC/DIFFCALCV312/ComputeGlyphMaps
  Reason: image not found
Abort trap: 6

Note the path from which it tries to load that library (it seems to be hardcoded?!) The libary is also nowhere to be found in the Tortoise dir.

Of course I could try to download and compile VTK, create that path (or use otool) and put it there, but I feel I should not need to do this.


Is there anything I'm doing wrong? Has somebody tried to run this under MacOS?